import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "E\\K\\S+";
final String string = " X12 IK 888T\n"
+ " G I5J P9\n"
+ " 544T ZUK ONI\n"
+ " E6U5 Z339988 T8 N55\n"
+ " 886 W 9ZT T95";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}