re = /E\K\S+/m
str = ' X12 IK 888T
G I5J P9
544T ZUK ONI
E6U5 Z339988 T8 N55
886 W 9ZT T95'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end