#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:a*(?:ha*){2,}h?)\b|\b(?:a*(?:ja*)+j?)\b|\b(?:e*(?:je*)+j?)\b|\b(?:i*(?:ji+)+j?)\b|\b(?:A*(?:JA+)+J?)\b|\b(?:A*(?:HA+)+H?)\b|\b(?:e*(?:he+){2,}h?)\b|\b(?:Ja*(?:ja+)+j?)\b|\b(?:Je*(?:je+)+j?)\b|\bJa+\b|\b(?:Ji*(?:ji+)+j?)\b|\b(?:Ha*(?:ha+)+h?)\b|\b(?:Jo*(?:jo+)+j?)\b|\b(?:o*(?:jo+)+j?)\b|\b(?:a*((?:ja+)|(?:js+))+j?)\b|\b(?:A*((?:JA+)|(?:JS+))+J?)\b"
Local $sString = "jajajajajaja" & @CRLF & _
"jejejejeje" & @CRLF & _
"jijijijijij" & @CRLF & _
"ji" & @CRLF & _
"ja" & @CRLF & _
"je" & @CRLF & _
"hahahahahahaaaaa" & @CRLF & _
"Hahahaaa" & @CRLF & _
"Hahaaahaaha" & @CRLF & _
"hahaahaaaah" & @CRLF & _
"haaaaahaaahahahaaaaah" & @CRLF & _
"heheeheheeeeheeeheh" & @CRLF & _
"jajajaj" & @CRLF & _
"jaja" & @CRLF & _
"ja" & @CRLF & _
"jejejej" & @CRLF & _
"jeje" & @CRLF & _
"je" & @CRLF & _
"jijijiji" & @CRLF & _
"jiji" & @CRLF & _
"ji" & @CRLF & _
"ajajajaja" & @CRLF & _
"ahahahaha" & @CRLF & _
"ejejejeje" & @CRLF & _
"aaajajaja" & @CRLF & _
"jajaaajajaaajaaaa" & @CRLF & _
"JAJAJAJAJAJAJAJ" & @CRLF & _
"HAHAHAHAAAAHAHAHAHAAA" & @CRLF & _
"Hahahahahaha" & @CRLF & _
"JAJAJAJA" & @CRLF & _
"AAJAJAJA" & @CRLF & _
"JAJAAAJAJAJAAAAJ" & @CRLF & _
"he " & @CRLF & _
"hehe" & @CRLF & _
"haha" & @CRLF & _
"ha " & @CRLF & _
"has " & @CRLF & _
"hamaca " & @CRLF & _
"Jajajajaja" & @CRLF & _
"Jaja" & @CRLF & _
"Jejejejejeje" & @CRLF & _
"Jaa" & @CRLF & _
"Jijijijiiiiji" & @CRLF & _
"jiiijijijiiijijijiii " & @CRLF & _
"Jojojojojoj" & @CRLF & _
"jojojoj " & @CRLF & _
"Hahaa " & @CRLF & _
"Jejeee" & @CRLF & _
"jajaaaa" & @CRLF & _
"Jajaaaa" & @CRLF & _
"jajaj" & @CRLF & _
"jajajajsjaja" & @CRLF & _
"jajajssjsjsjajsja" & @CRLF & _
"jsjsjsjsjsjsj" & @CRLF & _
"JAJAJSJAJSSJAJSJSJAJSSSSJ " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")