# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:a*(?:ha*){2,}h?)\b|\b(?:a*(?:ja*)+j?)\b|\b(?:e*(?:je*)+j?)\b|\b(?:i*(?:ji+)+j?)\b|\b(?:A*(?:JA+)+J?)\b|\b(?:A*(?:HA+)+H?)\b|\b(?:e*(?:he+){2,}h?)\b|\b(?:Ja*(?:ja+)+j?)\b|\b(?:Je*(?:je+)+j?)\b|\bJa+\b|\b(?:Ji*(?:ji+)+j?)\b|\b(?:Ha*(?:ha+)+h?)\b|\b(?:Jo*(?:jo+)+j?)\b|\b(?:o*(?:jo+)+j?)\b|\b(?:a*((?:ja+)|(?:js+))+j?)\b|\b(?:A*((?:JA+)|(?:JS+))+J?)\b"
test_str = ("jajajajajaja\n"
"jejejejeje\n"
"jijijijijij\n"
"ji\n"
"ja\n"
"je\n"
"hahahahahahaaaaa\n"
"Hahahaaa\n"
"Hahaaahaaha\n"
"hahaahaaaah\n"
"haaaaahaaahahahaaaaah\n"
"heheeheheeeeheeeheh\n"
"jajajaj\n"
"jaja\n"
"ja\n"
"jejejej\n"
"jeje\n"
"je\n"
"jijijiji\n"
"jiji\n"
"ji\n"
"ajajajaja\n"
"ahahahaha\n"
"ejejejeje\n"
"aaajajaja\n"
"jajaaajajaaajaaaa\n"
"JAJAJAJAJAJAJAJ\n"
"HAHAHAHAAAAHAHAHAHAAA\n"
"Hahahahahaha\n"
"JAJAJAJA\n"
"AAJAJAJA\n"
"JAJAAAJAJAJAAAAJ\n"
"he \n"
"hehe\n"
"haha\n"
"ha \n"
"has \n"
"hamaca \n"
"Jajajajaja\n"
"Jaja\n"
"Jejejejejeje\n"
"Jaa\n"
"Jijijijiiiiji\n"
"jiiijijijiiijijijiii \n"
"Jojojojojoj\n"
"jojojoj \n"
"Hahaa \n"
"Jejeee\n"
"jajaaaa\n"
"Jajaaaa\n"
"jajaj\n"
"jajajajsjaja\n"
"jajajssjsjsjajsja\n"
"jsjsjsjsjsjsj\n"
"JAJAJSJAJSSJAJSJSJAJSSSSJ \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.