#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]|[1-9][0-9]|[12][0-9]{2}|3[0-5][0-9]|36[0-6])$"
Local $sString = "Example Matches:" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"99" & @CRLF & _
"366" & @CRLF & _
"159" & @CRLF & _
"Example Match Failures:" & @CRLF & _
"" & @CRLF & _
"01" & @CRLF & _
"001" & @CRLF & _
"099" & @CRLF & _
"367" & @CRLF & _
"999" & @CRLF & _
"0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")