re = /^(?:[1-9]|[1-9][0-9]|[12][0-9]{2}|3[0-5][0-9]|36[0-6])$/m
str = 'Example Matches:
1
99
366
159
Example Match Failures:
01
001
099
367
999
0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end