$re = '/\s(19|20)[0-9]{2}\s(?!\s(19|20)[0-9]{2}\s)/';
$str = 'ACB 19000 XY4Z 1910 ACBDEFGH12I 1955-1954 3400 2100 3400 1934 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);