import Foundation
let pattern = #"\s(19|20)[0-9]{2}\s(?!\s(19|20)[0-9]{2}\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ACB 19000 XY4Z 1910 ACBDEFGH12I 1955-1954 3400 2100 3400 1934 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)