import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(20\\d{2})-(0[1-9]|1[0-2])-([01][\\d]|3[01])[\\sT]([01]\\d|2[0-3]):([0-5]\\d):([0-5]\\d)(Z|[\\+-](0[\\d]|1[\\d]|2[0-3]):([0-5]\\d))?";
final String string = "2023-01-01 00:00:00Z\n"
+ "2023-12-31 23:59:59+00:00\n"
+ "2023-06-06 13:47:23-06:00\n"
+ "2023-06-06T13:47:23+23:45\n"
+ "2023-06-06T13:47:23";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}