const regex = /(20\d{2})-(0[1-9]|1[0-2])-([01][\d]|3[01])[\sT]([01]\d|2[0-3]):([0-5]\d):([0-5]\d)(Z|[\+-](0[\d]|1[\d]|2[0-3]):([0-5]\d))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(20\\d{2})-(0[1-9]|1[0-2])-([01][\\d]|3[01])[\\sT]([01]\\d|2[0-3]):([0-5]\\d):([0-5]\\d)(Z|[\\+-](0[\\d]|1[\\d]|2[0-3]):([0-5]\\d))?', 'g')
const str = `2023-01-01 00:00:00Z
2023-12-31 23:59:59+00:00
2023-06-06 13:47:23-06:00
2023-06-06T13:47:23+23:45
2023-06-06T13:47:23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}