# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\+?1-?\(?(\d{3})\)?[- ]?(\d{3})\-?(\d{4})$"
test_str = ("19999999999\n"
"+19999999999\n"
"1-999-999-9999\n"
"1-(999) 999-9999\n"
"1238934265981239")
subst = "1($1) $2-$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.