const regex = /\/\/(?:www\.)?(.+?)\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/(?:www\\.)?(.+?)\\\/', 'g')
const str = `(http://web.archive.org/web/20080620033027/http://www.mrvc.indianrail.gov.in/overview.htm)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}