$re = '/\/\/(?:www\.)?(.+?)\//';
$str = '(http://web.archive.org/web/20080620033027/http://www.mrvc.indianrail.gov.in/overview.htm)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);