$re = '/([[:word:]]{4,})(?!.*\1)/m';
$str = 'The Lord\'s right hand is lifted high; the Lord\'s right hand has done mighty things!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);