re = /([[:word:]]{4,})(?!.*\1)/m
str = 'The Lord\'s right hand is lifted high; the Lord\'s right hand has done mighty things!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end