const regex = /from\s+(\d+).*([a-zA-Z0-9]{10})\s+at\s+(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('from\\s+(\\d+).*([a-zA-Z0-9]{10})\\s+at\\s+(.*)', 'gm')
const str = `Cash In Tk 500.00 from 01789788881 successful. Fee Tk 0.00. Balance Tk 4,145.08. TrxID 6E63D2OS4R at 06/05/2019 20:24`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}