re = /from\s+(\d+).*([a-zA-Z0-9]{10})\s+at\s+(.*)/m
str = 'Cash In Tk 500.00 from 01789788881 successful. Fee Tk 0.00. Balance Tk 4,145.08. TrxID 6E63D2OS4R at 06/05/2019 20:24'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end