using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http://|https://|ftp://|mailto:|www\.){1}(?![^>]*<)(?![^""]*"")[^^\\\""\n\s\}\{\|\`<>~]*";
string input = @"Content <strong>http://www.website.com/test</strong> with a hyperlink <a href=""www.google.com"">www.google.com</a> and also a normal link www.youtube.com dsdsd sometexthttp://www.hello.com/test sdfsdfsdfg ssdgsdf sdfsdfsdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}