re = /(http:\/\/|https:\/\/|ftp:\/\/|mailto:|www\.){1}(?![^>]*<)(?![^"]*")[^^\\\"\n\s\}\{\|\`<>~]*/m
str = 'Content <strong>http://www.website.com/test</strong> with a hyperlink <a href="www.google.com">www.google.com</a> and also a normal link www.youtube.com dsdsd sometexthttp://www.hello.com/test sdfsdfsdfg ssdgsdf sdfsdfsdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end