$re = '/^[^\s+.]+.\K(\S+\S)/';
$str = '[Vivid-Asenshi] Violet Evergarden - 02 [53E58502].mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);