re = /^[^\s+.]+.\K(\S+\S)/
str = '[Vivid-Asenshi] Violet Evergarden - 02 [53E58502].mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end