package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Software Version (\d.\d{1,2}(?:\(?\d{1,2}?\)?\d{1,2}?)?)\W*$`)
var str = `Cisco Adaptive Security Appliance Software Version 9.12(1)2
ASAv1 up 23 mins 50 secs
Serial Number: 9A2AL26E95V`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}