import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Software Version (\\d.\\d{1,2}(?:\\(?\\d{1,2}?\\)?\\d{1,2}?)?)\\W*$";
final String string = "Cisco Adaptive Security Appliance Software Version 9.12(1)2 \n"
+ "ASAv1 up 23 mins 50 secs\n"
+ "Serial Number: 9A2AL26E95V";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}