using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"R\d+:";
string input = @"R1:C1[6]|R1:C1[12]-[P1_G]";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}