const regex = /R\d+:/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('R\\d+:', 'm')
const str = `R1:C1[6]|R1:C1[12]-[P1_G]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}