const regex = /^(?:[^_\n]*_){2}([^_\n]*(?:_[^_\n]*+)*)_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^_\\n]*_){2}([^_\\n]*(?:_[^_\\n]*+)*)_', 'gm')
const str = `Problem_ISOAPAPattern_Pat_2nd_byUser-withAllRoles_351107b7-88eb-4232-9107-b788eb92325b
Pat_2nd_byUser-withAllRoles
Problem_ISOACompressionPattern_pattern 7cbc_7cbce13c-0b25-49a4-bce1-3c0b2569a411
pattern 7cbc `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}