$re = '/^(?:[^_\n]*_){2}([^_\n]*(?:_[^_\n]*+)*)_/m';
$str = 'Problem_ISOAPAPattern_Pat_2nd_byUser-withAllRoles_351107b7-88eb-4232-9107-b788eb92325b
Pat_2nd_byUser-withAllRoles
Problem_ISOACompressionPattern_pattern 7cbc_7cbce13c-0b25-49a4-bce1-3c0b2569a411
pattern 7cbc ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);