#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]{1,}.*?\d+-\d+-\d+-\d+[\s\S]*?\s{3,}\d+-\d+-\d+-[A-Za-z0-9]{4}"
Local $sString = " DATE: 02 July 2019 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" -------------------------------------------------------------------------------------------- " & @CRLF & _
" WELL NAME LICENCE NUMBER MINERAL RIGHTS GROUND ELEVATION " & @CRLF & _
" UNIQUE IDENTIFIER SURFACE CO-ORDINATES BOARD FIELD CENTRE PROJECTED DEPTH " & @CRLF & _
" LAHEE CLASSIFICATION FIELD TERMINATING ZONE " & @CRLF & _
" DRILLING OPERATION WELL PURPOSE WELL TYPE SUBSTANCE " & @CRLF & _
" LICENSEE SURFACE LOCATION " & @CRLF & _
" -------------------------------------------------------------------------------------------- " & @CRLF & _
"" & @CRLF & _
" MEG K7N HARDY 4-7-77-5 0483923 ALBERTA CROWN 571.7M " & @CRLF & _
" 106/04-07-077-05W4/02 S 572.4M W 278.3M BONNYVILLE 1600.0M " & @CRLF & _
" DEV (NC) HARDY MCMURRAY FM " & @CRLF & _
" HORIZONTAL RESUMPTIONPRODUCTION (SCHEME) CRUDE BITUMEN " & @CRLF & _
" MEG ENERGY CORP. 09-07-077-05W4 " & @CRLF & _
"" & @CRLF & _
" SPL 11-24 HZ MARTEN 14-25-76-6 0494994 ALBERTA CROWN 705.3M " & @CRLF & _
" 100/14-25-076-06W5/00 S 566.0M E 800.6M ST. ALBERT 2700.0M " & @CRLF & _
" OUT (C) MARTEN CLEARWATER FM " & @CRLF & _
" HORIZONTAL NEW PRODUCTION CRUDE OIL " & @CRLF & _
" SPUR PETROLEUM LTD. 11-24-076-06W5 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")