import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{1,}.*?\\d+-\\d+-\\d+-\\d+[\\s\\S]*?\\s{3,}\\d+-\\d+-\\d+-[A-Za-z0-9]{4}";
final String string = " DATE: 02 July 2019 \n\n\n"
+ " -------------------------------------------------------------------------------------------- \n"
+ " WELL NAME LICENCE NUMBER MINERAL RIGHTS GROUND ELEVATION \n"
+ " UNIQUE IDENTIFIER SURFACE CO-ORDINATES BOARD FIELD CENTRE PROJECTED DEPTH \n"
+ " LAHEE CLASSIFICATION FIELD TERMINATING ZONE \n"
+ " DRILLING OPERATION WELL PURPOSE WELL TYPE SUBSTANCE \n"
+ " LICENSEE SURFACE LOCATION \n"
+ " -------------------------------------------------------------------------------------------- \n\n"
+ " MEG K7N HARDY 4-7-77-5 0483923 ALBERTA CROWN 571.7M \n"
+ " 106/04-07-077-05W4/02 S 572.4M W 278.3M BONNYVILLE 1600.0M \n"
+ " DEV (NC) HARDY MCMURRAY FM \n"
+ " HORIZONTAL RESUMPTIONPRODUCTION (SCHEME) CRUDE BITUMEN \n"
+ " MEG ENERGY CORP. 09-07-077-05W4 \n\n"
+ " SPL 11-24 HZ MARTEN 14-25-76-6 0494994 ALBERTA CROWN 705.3M \n"
+ " 100/14-25-076-06W5/00 S 566.0M E 800.6M ST. ALBERT 2700.0M \n"
+ " OUT (C) MARTEN CLEARWATER FM \n"
+ " HORIZONTAL NEW PRODUCTION CRUDE OIL \n"
+ " SPUR PETROLEUM LTD. 11-24-076-06W5 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}