#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?|ftp):\/\/(?!\W*www\.)\S+$"
Local $sString = "http://example.com" & @CRLF & _
"http://example.com/path1/path2?hello=1&hello=2" & @CRLF & _
"http://a" & @CRLF & _
"http://abc" & @CRLF & _
"" & @CRLF & _
"http:/example.com" & @CRLF & _
"http://exampl e.com" & @CRLF & _
"http:// exampl e.com" & @CRLF & _
"http://example.com // Trailing space" & @CRLF & _
"http:// example.com" & @CRLF & _
"http:///www.example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")