re = /^(https?|ftp):\/\/(?!\W*www\.)\S+$/m
str = 'http://example.com
http://example.com/path1/path2?hello=1&hello=2
http://a
http://abc
http:/example.com
http://exampl e.com
http:// exampl e.com
http://example.com // Trailing space
http:// example.com
http:///www.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end