package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I ?['a]m ([a-zA-Z]+)`)
var str = `"I'm sam"
I am good at this
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}