$re = '/I ?[\'a]m ([a-zA-Z]+)/m';
$str = '"I\'m sam"
I am good at this
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);