import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(10|127|169\\.254|192\\.168|172\\.(2[0-9]|1[6-9]|3[0-1])|(25[6-9]|2[6-9][0-9]|[3-9][0-9][0-9]|99[1-9]))\\.)[0-9]{1,3}(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}$";
final String string = "Public ranges\n"
+ "1.0.0.0-9.255.255.255\n"
+ "11.0.0.0-100.63.255.255\n"
+ "100.128.0.0-126.255.255.255\n"
+ "128.0.0.0-169.253.255.255\n"
+ "169.255.0.0-172.15.255.255\n"
+ "172.32.0.0-191.255.255.255\n"
+ "192.0.1.0/24\n"
+ "192.0.3.0-192.88.98.255\n"
+ "192.88.100.0-192.167.255.255\n"
+ "192.169.0.0-198.17.255.255\n"
+ "198.20.0.0-198.51.99.255\n"
+ "198.51.101.0-203.0.112.255\n"
+ "203.0.114.0-223.255.255.255\n\n"
+ "------OK------\n"
+ "1.1.1.1\n"
+ "9.255.255.255\n"
+ "11.0.0.0\n"
+ "126.255.255.255\n"
+ "128.0.0.0\n"
+ "169.253.255.255\n"
+ "169.255.0.0\n"
+ "172.15.255.255\n"
+ "172.32.0.0\n"
+ "192.167.255.255\n"
+ "192.169.0.0\n\n"
+ "-----NOT OK-----\n"
+ "10.0.0.0\n"
+ "10.255.255.255\n"
+ "127.0.0.0\n"
+ "127.255.255.255\n"
+ "169.254.0.255\n"
+ "169.254.255.255\n"
+ "172.16.0.0\n"
+ "172.31.255.255\n"
+ "192.168.0.0\n"
+ "192.168.255.255\n\n"
+ "Not including test nets\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}