const regex = /^(?!(10|127|169\.254|192\.168|172\.(2[0-9]|1[6-9]|3[0-1])|(25[6-9]|2[6-9][0-9]|[3-9][0-9][0-9]|99[1-9]))\.)[0-9]{1,3}(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(10|127|169\\.254|192\\.168|172\\.(2[0-9]|1[6-9]|3[0-1])|(25[6-9]|2[6-9][0-9]|[3-9][0-9][0-9]|99[1-9]))\\.)[0-9]{1,3}(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}$', 'gm')
const str = `Public ranges
1.0.0.0-9.255.255.255
11.0.0.0-100.63.255.255
100.128.0.0-126.255.255.255
128.0.0.0-169.253.255.255
169.255.0.0-172.15.255.255
172.32.0.0-191.255.255.255
192.0.1.0/24
192.0.3.0-192.88.98.255
192.88.100.0-192.167.255.255
192.169.0.0-198.17.255.255
198.20.0.0-198.51.99.255
198.51.101.0-203.0.112.255
203.0.114.0-223.255.255.255
------OK------
1.1.1.1
9.255.255.255
11.0.0.0
126.255.255.255
128.0.0.0
169.253.255.255
169.255.0.0
172.15.255.255
172.32.0.0
192.167.255.255
192.169.0.0
-----NOT OK-----
10.0.0.0
10.255.255.255
127.0.0.0
127.255.255.255
169.254.0.255
169.254.255.255
172.16.0.0
172.31.255.255
192.168.0.0
192.168.255.255
Not including test nets
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}