const regex = new RegExp('^([^=]+)==.*\\n\\1==', 'ms')
const str = `agate==1.6.0
agate==1.7.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}