$re = '/^([^=]+)==.*\n\1==/ms';
$str = 'agate==1.6.0
agate==1.7.0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);