import re
regex = re.compile(r"\[json]:#.\(([^*]*)\)")
test_str = ("# Title\n\n"
"## 1. Conclusion\n"
"Jada, jada\n\n"
"## 2. Recomendation\n"
"blah, blah\n\n"
"[json]:# (\n"
"[\n"
" {\"sensitivity\": \"internal\"}\n"
"]\n"
")\n\n"
"More data\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)