re = /\[json]:#.\(([^*]*)\)/
str = '# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{"sensitivity": "internal"}
]
)
More data
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result