const regex = /^\$[a-z0-9_]+$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$[a-z0-9_]+$', 'gmu')
const str = `key1
key2
\$internal_field1
\$internal_field2
\$NOT_INTERNAL_FIELD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}