// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^\$[a-z0-9_]+$").unwrap();
let string = "key1
key2
$internal_field1
$internal_field2
$NOT_INTERNAL_FIELD";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}