package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(-\w+)*$`)
var str = `Ya-Mo
Ya-Mo-Ga
Ya--Mo
Ya---Mo
-Ya
-Ya-Mo-
Ya-
ya`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}