$re = '/^\w+(-\w+)*$/m';
$str = 'Ya-Mo
Ya-Mo-Ga
Ya--Mo
Ya---Mo
-Ya
-Ya-Mo-
Ya-
ya';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);