$re = '/[\w-:]+(?=\s*=\s*".*?")/';
$str = '<div class="foo">
<span data-text="Some string" class="bar"></span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);