re = /[\w-:]+(?=\s*=\s*".*?")/
str = '<div class="foo">
<span data-text="Some string" class="bar"></span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end