re = /location \/api.*?proxy_pass\s*([^\s;]+)/m
str = 'server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}'
subst = 'http://localhost:1234'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result