import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "num_externe\\s*=(?'num_externe'.*?)\\s*xfi_cd.*ins_numins\\s*=(?'ins_numins'.*?)\\s*apt_nom\\s*=(?'apt_nom'.*?)\\s*apt_type\\s*=(?'apt_type'.*?)\\s*apt_telephone\\s*=(?'apt_telephone'.*?)\\s*tsy_cd\\s*=(?'tsy_cd'.*?)\\s*qsy_cd\\s*=(?'qsy_cd'.*?)\\s*commentaire_externe\\s*=(?'commentaire_externe'.*?)\\s*apt_localisation\\s*=(?'apt_localisation'.*?)\\s*urg_cd";
final String string = " \n"
+ " \n"
+ " num_externe=1607770.01 xfi_cd=E ins_numins=5490201001 apt_nom=AMMAR/Fathia apt_type=CLI\n"
+ "apt_telephone=0156658495 tsy_cd=3116 qsy_cd=1 commentaire_externe=B490 - RETIRER LE NÉON QUI SE TROUVE AU DESSUS DU BUREAU SVP MERCI apt_localisation=B463////Courbevoie urg_cd= dtheure_limite= \n"
+ " \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}