re = /num_externe\s*=(?'num_externe'.*?)\s*xfi_cd.*ins_numins\s*=(?'ins_numins'.*?)\s*apt_nom\s*=(?'apt_nom'.*?)\s*apt_type\s*=(?'apt_type'.*?)\s*apt_telephone\s*=(?'apt_telephone'.*?)\s*tsy_cd\s*=(?'tsy_cd'.*?)\s*qsy_cd\s*=(?'qsy_cd'.*?)\s*commentaire_externe\s*=(?'commentaire_externe'.*?)\s*apt_localisation\s*=(?'apt_localisation'.*?)\s*urg_cd/m
str = '
num_externe=1607770.01 xfi_cd=E ins_numins=5490201001 apt_nom=AMMAR/Fathia apt_type=CLI
apt_telephone=0156658495 tsy_cd=3116 qsy_cd=1 commentaire_externe=B490 - RETIRER LE NÉON QUI SE TROUVE AU DESSUS DU BUREAU SVP MERCI apt_localisation=B463////Courbevoie urg_cd= dtheure_limite=
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end