#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<abr:rules>((?!subapplication=).)*subapplication="(?!CM")[^"]+"((?!<\/abr:rules>).)*<\/abr:rules>"
Local $sString = "<abr:rules>" & @CRLF & _
"<abr:ruleTypeDefinition>" & @CRLF & _
"<abr:code>ADE</abr:code>" & @CRLF & _
"<abr:ownership>" & @CRLF & _
"<abr:owner organization="NT" application="DCS" subapplication="AM"/>" & @CRLF & _
"...lines..." & @CRLF & _
"..........." & @CRLF & _
"</abr:rules>" & @CRLF & _
"<abr:rules>" & @CRLF & _
"<abr:ruleTypeDefinition>" & @CRLF & _
"<abr:code>ADE</abr:code>" & @CRLF & _
"<abr:ownership>" & @CRLF & _
"<abr:owner organization="NT" application="DCS" subapplication="CM"/>" & @CRLF & _
"...lines..." & @CRLF & _
"..........." & @CRLF & _
"</abr:rules><abr:rules>" & @CRLF & _
"<abr:ruleTypeDefinition>" & @CRLF & _
"<abr:code>ABB</abr:code>" & @CRLF & _
"<abr:ownership>" & @CRLF & _
"<abr:owner organization="NT" application="DCS" subapplication="CM"/>" & @CRLF & _
"...lines..." & @CRLF & _
"..........." & @CRLF & _
"</abr:rules>" & @CRLF & _
"<abr:rules>" & @CRLF & _
"<abr:ruleTypeDefinition>" & @CRLF & _
"<abr:code>ADE</abr:code>" & @CRLF & _
"<abr:ownership>" & @CRLF & _
"<abr:owner organization="NT" application="DCS" subapplication="CM"/>" & @CRLF & _
"...lines..." & @CRLF & _
"..........." & @CRLF & _
"</abr:rules>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")