package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+\s\w+|\d+.\d+)`)
var str = `John Doe 3.30 23123123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}